19th May 2017

Website Website loading slow

We are currently getting reports that the website is loading very slow.

UPDATE: Our hosting provider has told us this is due to an issue with the LetEncrypt service which provides the SSL certificate for rentpro.co.uk.

UPDATE: The issue has been resolved by our hosting provider. See full details from their outage report - https://manage.bigwetfish.hosting/announcements.php?id=370